Обновление модуля в виде расширения

Если модуль Контур.EDI был установлен через расширение и запускается как обработка, то для его обновления:

  1. Запустите 1С в пользовательском режиме.
  2. Откройте меню → «Все функции» (либо «Функции для технического специалиста»).
  3. В разделе «Стандартные» двойным нажатием откройте «Управление расширениями конфигурации».
  4. Выберите расширение модуля КонтурEDI и нажмите «Загрузить».
  5. Выберите файл с новым расширением и нажмите «Открыть».
  6. Нажмите «Перезапустить». Расширение обновлено.

Если при обновлении возникла ошибка:

«(Критичная) Контур EDI: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации» 

— обновите расширение через конфигуратор.

Как обновить расширение через конфигуратор

Чтобы исправить ошибку «(Критичная) Контур EDI: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации», обновите расширение через конфигуратор. Для этого:

  1. Важно! Сделайте резервную копию базы 1С.  
  2. Запустите конфигуратор.
  3. Нажмите пункт меню «Конфигурация» → «Расширения конфигурации».
  4. Выберите расширение Контур.EDI и в этом же окне нажмите «Конфигурация» → «Загрузить конфигурацию из файла...».
  5. Выберите файл с новой версией расширения → подтвердите замену текущей конфигурации, нажмите «Да».
  6. Подтвердите обновление конфигурации базы данных.
  7. Внизу окна 1С откроется «Проверка возможности применения», там будет указана ошибка расширения и ссылка «Исправить» в колонке «Действие». Нажмите «Исправить» → «Установить значение из объекта конфигурации».
    Если окно с ошибкой не появилось или вы его случайно закрыли, установите режим совместимости в расширении вручную. Как установить режим совместимости, см. в пунктах 8-10 инструкции «Установка и запуск модуля в виде расширения». 
  8. Сохраните расширение в базу данных, нажав на кнопку .
  9. Примите изменения.
  10. После исправления ошибки перезапустите 1С в пользовательском режиме и запустите расширение, проверьте версию обработки. 


База знаний